1. トップ >
  2. 製品・サービス情報 >
  3. biz-Stream >
  4. biz-Stream v5 各リリース・ホットフィックスでの動作環境

biz-Stream

biz-Stream v5 各リリース・ホットフィックスでの動作環境

■ 機能・インタフェース

● biz-Stream v5 ライブラリ

Version OS Java環境
5.0.0 Javaクラスライブラリとして提供されるため、Java動作環境対応OS上で稼動し、特定のOSに依存しません。 Java 7, 8
5.1.0 Java 7, 8, 11

● biz-Stream v5 レイアウト・デザイナ

Version OS Java実行環境
5.0.0 Microsoft Windows 7/8.1/10 インストール時に同梱されるOracle Corporation Java Runtime Environment 8 Update 151の使用を推奨します。
別途用意される場合の動作環境は以下のとおりです。
Java 7, 8
※ 64bit版OSを使用する場合、Java環境については32bit版をインストールする必要があります。
※ Java 8を使用する場合、Java 8 Update25以上をインストールする必要があります。
5.1.0 インストール時に同梱されるOpenJDK 11.0.1の使用を推奨します。
別途用意される場合の動作環境は以下のとおりです。
Java 7, 8, 11 (Java 11推奨)
※ 32bit OSではOracle JRE 8 Update 191がインストール時に同梱されます。

● biz-Stream v5 レイアウト・デザイナ for Excel

Version OS Excel
5.0.0 Microsoft Windows 7/8.1/10 Microsoft Excel 2010/2013/2016
5.1.0 Microsoft Excel 2010/2013/2016/2019
Microsoft Office 365

● biz-Stream v5 Webサービスサーバ

Version OS Java環境 サーブレット コンテナ
5.0.0 製品に同梱のApache Tomcat 8.5.23および、Java 8 Update 151が動作するオペレーティングシステム。※1 ※2 Java 8
※ 製品に同梱のOracle Corporation Java Runtime Environment 8 Update 151をご利用ください。
Apache Tomcat 8.5
※ 製品に同梱のApache Software Foundation Tomcat 8.5.23をご利用ください。
5.1.0 製品に同梱のApache Tomcat 8.5.35および、OpenJDK 11.0.1が動作するオペレーティングシステム。※1 ※2 Java 11 Apache Tomcat 8.5
※ 製品に同梱のApache Software Foundation Tomcat 8.5.35をご利用ください。

※1 Apache Tomcatのサポート対象システム構成につきましては、Apache Software Foundationにお問い合わせください。
※2 Javaのサポート対象システム構成につきましては、Oracle社にお問い合わせください。

● biz-Stream v5.1 Webサービスインターフェイス (クライアント)
Version 対応規格
5.0.0 W3C SOAP 1.1/1.2、WS-Addressing、MTOM(SOAP Message Transmission Optimization Mechanism)、WS-Security規格に準拠しているソフトウェア
※ Java Development KitまたはMicrosoft Visual Studioにおいて、biz-Stream WebサービスサーバのWSDLから自動生成されるスタブクラスの使用を推奨します。
※ その他、上記規格に準拠したSOAPメッセージを送受信可能なソフトウェアも利用可能です。
5.1.0

● biz-Stream v5 ダイレクト印刷 クライアントモジュール

Version OS 対応ブラウザ PDFビューア 製品に同梱されるその他のライブラリ等
5.0.0 Microsoft Windows 7/8.1/10 Microsoft Internet Explorer 11
Microsoft Edge
Google Chrome
Mozilla Firefox
※ Microsoft Internet Explorer以外はターゲット機能が動作しません
Adobe Acrobat DC/Acrobat Reader DC
※ PDFファイルを閲覧できることを事前に確認してください。
Microsoft .NET Framework 4.6/
Microsoft MSXML 6.0 SP1
5.1.0

● biz-Stream v5 バッチ印刷モジュール

Version OS PDFビューア 製品に同梱されるその他のライブラリ等
5.0.0 Microsoft Windows 7/8.1/10
Microsoft Windows Server 2008(32bit版) SP2/2008 R2/2012/2012 R2/2016
Adobe Acrobat DC/Acrobat Reader DC
※ PDFファイルを閲覧できることを事前に確認してください。
Microsoft .NET Framework 4.6/
Microsoft MSXML 6.0 SP1
5.1.0 Microsoft Windows 7/8.1/10
Microsoft Windows Server 2008(32bit版) SP2/2008 R2/2012/2012 R2/2016/2019
  • 資料請求・ダウンロード
  • お問合せ